Asus M2N-SLI Deluxe Motherboard Won't Post After BIOS Update

I have an old Asus AMD AM2+ compatible motherboard that I'm using as the basis for a headless server for web hosting, automated backups, Bittorrent seeding, and a bitcoin node.  To Asus' credit, they're still supporting the thing with documentation and software downloads all of these years later.

As part of the server conversion, I picked up a bunch of off-brand DDR2 RAM on Ebay—it identifies itself as "Kingston Shenzhen" or some nonsense in memtest86—that turned out to be of the questionably-compatible high-density variety.  After mixing every possible combination of low-density and high-density RAM, I found that the this motherboard will happily take high-density RAM as long as only two or three of the four available RAM slots are populated.  It didn't matter if the third and fourth sticks were a matched pair of low-density RAM, the thing would freeze during the power-on self test (POST).  Sometimes you get what you pay for.

"Upgrading the BIOS" (basic input/output system) is a sort of can't-hurt-might-help black magic proposed on forums for curing every possible computer problem.  There is no reason to think it should help except in extremely specific situations, and if something goes wrong with the BIOS "flash" write operation your hardware is now a very advanced paperweight.  The risk just isn't worth flashing a new BIOS for no reason.

...but inevitably, over the hundreds of computers I've worked on, there was that one damn time when it inexplicably fixed the problem.  I really wanted to put some more RAM in this server, so I downloaded the newest version and rolled the dice.

working on this same machine shortly after I acquired it, back in November of 2012!

Attempting to flash the BIOS through software that runs inside your operating system is a fantastic way to improve the odds you'll end up with a fancy brick.  Tried-and-true methods include booting into DOS—yes, the good old 1980's Disk Operating System—and flashing from there, or using a special utility built right into the board's firmware to flash right from POST.  ASUS motherboards have just such an "EZ Flash" utility.

I dropped the latest BIOS on a flash drive—it had to be some ridiculously small size for EZ Flash to see it, but luckily I found an ancient 1GB drive left in the very back of my office desk by some Cro-Magnon predecessor to modern graduate students—and followed the EZ Flash prompts.  The progress bar went to 100%, everything looked pretty good, and the machine restarted on its own. 

Black screen. No keyboard lights.  No beep code.

Cleared the nonvolatile BIOS CMOS memory... still nothing.

At this point I started feeling pretty stupid.  Some modern motherboard manufacturers are progressive enough to put the BIOS on a socketed chip for easy replacement, but this board's flash memory was very firmly soldered in place.  While it's possible to purchase a new chip from places like badflash.com and attempt to desolder and replace the chip on a hot-air rework station, the process is rather painful.  The $30 for a fresh chip is definitely more than this motherboard is worth now.

So I popped the little CMOS watch battery out of its holder, unplugged the power supply from the wall, and took a walk.

Thirty minutes later, I replaced the battery, plugged in the power supply, and temporarily shorted the motherboard's power pins to start up the power supply.  Success!

I found out later that ASUS refers to this procedure as "CPR" (CPU Parameter Recall) in their documentation.  Sometimes it pays to RTFM, even when it's written in Chinglish.

The BIOS update did not improve the RAM compatibility.  As expected.  Two sticks it is!